Garbled audio recordings withLive / Ebo > Syphon using SWB Audio Capture

Hi and thanks for your awesome work!

I’m trying to record Live audio through Syphon via SWB Audio Capture on latest Mac Big Sur 11.3.1 with Focusrite Clarett 4Pre Thunderbolt interface. I hear audio just fine through the Focusrite while recording to Syphon (via SWB preview), but when playing the recording back in QT Player or Finder I just hear a quick burst of garbled audio, then silence.

FYI, I actually just finally upgraded to Big Sur in order to run SWB Audio Capture because iShowU Audio Capture seems to be deprecated by SWB and I was having difficulty getting it to work on Catalina.

Focusrite Clarett 4Pre Thunderbolt interface is set to 48k internal clock via Focusrite Control software panel. Audio MIDI Setup shows Focusrite bit depth to be 24-bit integer, but no control over bit depth.

Ableton > Preferences > Audio output is set for SWB Audio Capture (2 in, 2 out). In/Out Sample Rate = 48k. Latency Buffer Size = 1024 samples. I see no display of or control over bit depth.

In Audio MIDI Setup, SWB Audio Capture is set for 48k 32-bit float on both Input and Output. I see no control over bit depth. SWB Audio Capture preview is enabled (green icon lit in menu bar), with preview routed to Focusrite Thunderbolt (main Sound output).

Syphon input is set to SWB Audio Capture. With Syphon audio format set to use Linear PCM, QT Player shows the recorded audio to be 16-bit little-endian signed integer, 48000 Hz. Changing Syphon to AAC or Apple Lossless yields the same distorted garble.

I have restarted but no change. I’m running the very latest versions of everything involved.

The most obvious thing I can find is the difference in the bit depths between Live, SWB and Focusrite but, again, I find no controls for bit depth anywhere.

FWIW, while I don’t remember deleting iShowU Audio Capture, it is no longer appearing as an option anywhere in audio I/O selections. So there might be vestiges of it in the system, but SWB site says they can coexist.

Thanks so much for you help!


Update: While I originally said that I hear audio just fine while recording, I’ve just realized that I’m experiencing noticeable latency even at the lowest Live audio buffer size settings.

Also, I’ve uninstalled and reinstalled SWB Audio Capture… no change to the issue.

Additional Update: I’ve now tried Loopback from Rogue Amoeba instead of SWB Audio Capture. No change.

I’ve also tried bypassing the Focusrite Clarett 4Pre completely and outputting only the Mac’s internal speakers, clock source = default. No change.

I’ve also now tried switching from 48k to 44.1k in Ableton prefs ,and verified in Audio MIDI Setup that the internal speaker ouput is also at 44.1 (shows 32-bit float, clock source = default). Syphon prefs set to record Loopback. But no matter what I do, the resulting Syphon movie audio is always 48k Linear PCM, 16 bit little-endian signed integer.

In all cases, the garbled audio sounds like it might just be whipping through the audio super fast and glitching it up in the process. When recording at 48k, the pitch of the garble seems to be accurate and consistent. When recording at 44.1 the pitch is off, but consistent. So it really feels like it has to do with sample rate… and possibly Syphon Recorder being locked into an audio spec that is not flexible to accommodate the source spec?

Help is greatly appreciated, thanks!

Hi Jeff, sorry for the long silence
The internal audio loop back software is always a sensitive part of mac os which is prone to break with every Mac OS update. I think from this topic you found a working solution? Syphon Recorder audio problem under Big Sur

Btw, in these cases it is often hard to know why it doesn’t work.