Syphon Recorder audio problem under Big Sur

Does anyone have success or experience with Syphon Recorder under Big Sur on Intel Macs?

Using Ebo Suite, I’m routing audio from Live to Syphon Recorder via Loopback (also tried SWB Audio Capture now that iShowU Instant doesn’t work with Big Sur). In my recorded output, video is fine, but the audio is always garbled in a way that sounds like issues with sample rate, bit depth and/or clock… even with just internal speaker and no external interface. The recorded file specs always come out as 16-bit little-endian signed integer 48k even in tests at 44.1k.

Syphon Recorder support and updates do not appear to be current… with no mention of Big Sur support.

I’m also very open to alternatives for recording Live audio at the same time as Ebo’s Syphon’d video outpot.

Thanks so much!

Update: Big Sur 11.4 update didn’t solve the issue… but OBS instead of Syphon Recorder is working. Yay!

Related in case it helps anyone: Am now happily using Loopback. SWB Audio Capture has significant latency at this wriring (a known issue the dev says he’s working on), and I couldn’t get Blackhole working properly. Loopback may be the more expensive option, but it’s worth it for the grief it’s saved me!

2 Likes

good to hear!
We will also let you know if we find other workable situations

hi @jeffburger

I’ve never heard of LoopBack but I’m looking into it. Are you using it to get audio into Syphon the way you want, or are you using it for OBS? I will look into OBS, but I like Syphon because it records alpha channels and that is a crucial part of my workflow for ebosuite.

Hi Scott,

Yes, Loopback works perfectly for me, set for audio out pref in Live and audio in pref in Syphon Recorder.
In fact, Loopback is the only interapp audio solution I did get to work without issues. It’s more of an investment that the other solutions, but it simply works.

Loopback does work with OBS, however I seem to be OK with Syphon Recorder now. More on that below if it helps anyone…

This arcane combo of hardware, software, apps, etc. has been really insane to troubleshoot. My glitchy audio/video issues seemed to resolve after switching the Syphon Recorder codec from H.264 to Photo JPEG or ProRes… but then the issue returned after a while. I couldn’t think of any system changes I had made. Then it dawned on me that I had added Waves Abbey Road Studio plugin to the session and, with it, the separate but related Waves Nx Head Tracker app that seems to get down into the system. I’ve now successfully tested Abbey Road in a Live/Ebo session without Head Tracker and my recordings and post-recording system behavior seem to be fine again. No real understanding of why that would affect AV playback… but, call me crazy, I haven’t tried to break it again!

Hope that helps!

1 Like