Looking for installation requirements


#1

Cannot find the system installation requirements. Can someone point me in the right direction?


#2

Hi Jondon, the installation requirements are:

  • Mac OS 10.11+
  • Ableton Live 9.5+ (64 bit preferred)
  • Max for Live

You can find them here, at the bottom of this page:


#3

Awesome!.. Sorta… Need to purchase a new Ableton I guess. Thanks!